Static NAT on Cisco Router

Categories Cisco
NAT TOPOLOGY

we have to assign Gi0/0 as NAT inside interface and Gi0/1 as NAT outside interface on Router. This will tell the router that interesting traffic entering or exiting these two interfaces will be subject to address translation. Next we have to statically translate our inside local to inside global.

Router’s config:

Router#sh runn
Building configuration...

Current configuration : 3552 bytes
!
! Last configuration change at 02:33:55 UTC Sun Aug 2 2020
!
version 15.7
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
no ip icmp rate-limit unreachable
!
!
!
!
ip dhcp pool PETE
 network 192.168.1.0 255.255.255.0
 domain-name pete.lab
 default-router 192.168.1.1
 dns-server 8.8.8.8
!
!
!
ip domain name pete.lab
ip name-server 8.8.8.8
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
redundancy
!
lldp run
no cdp log mismatch duplex
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback2
 ip address 192.168.22.2 255.255.255.0
!
interface GigabitEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/1
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/3
 no ip address
 shutdown
 duplex auto
 speed auto
 media-type rj45
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip nat inside source static 192.168.1.2 192.168.122.156
ip route 0.0.0.0 0.0.0.0 192.168.122.1
!
ipv6 ioam timestamp
!
!
!
control-plane
!
banner exec ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS  *
* education. IOSv is provided as-is and is not supported by Cisco's      *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any       *
* purposes is expressly prohibited except as otherwise authorized by     *
* Cisco in writing.                                                      *
**************************************************************************^C
banner incoming ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS  *
* education. IOSv is provided as-is and is not supported by Cisco's      *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any       *
* purposes is expressly prohibited except as otherwise authorized by     *
* Cisco in writing.                                                      *
**************************************************************************^C
banner login ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS  *
* education. IOSv is provided as-is and is not supported by Cisco's      *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any       *
* purposes is expressly prohibited except as otherwise authorized by     *
* Cisco in writing.                                                      *
**************************************************************************^C
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
 transport input none
!
no scheduler allocate
!
end

From our Linux PC we ping out to google.com to test.

On our router we can see the address translation debug output.

debug ip nat
term mon

We can also look and see the statistics for our address translation:

sh ip nat stat

We can look at the translations that are occuring in an easy human readable format as well:

sh ip nat trans

20 Comments

  • styclaply
    01/24/2023

    Each experiment was performed 3 times with 3 4 replicates per treatment <a href=[Link deleted]for ear infection Tyrone RQApNIobQbWdErEGZ 6 18 2022

  • JamesBex
    01/27/2023

    [Link deleted]what can you give a dog for pain relief over the counter?

  • styclaply
    02/02/2023

    But the proud Ticton warriors can t end this match with a winless blood pressure medicine when coughing stops record <a href=[Link deleted]1mg But I get hot flashes from THINKING about hot flashes

  • styclaply
    02/03/2023

    The medium was mixed thoroughly, poured in a plate and then incubated at 37 C for 24 hrs <a href=[Link deleted]coupons

  • gate io platform
    02/25/2023

    Reading your article helped me a lot and I agree with you. But I still have some doubts, can you clarify for me? I’ll keep an eye out for your answers.

  • binance Konta Izveidosana
    04/28/2023

    Your point of view caught my eye and was very interesting. Thanks. I have a question for you. [Link deleted]

  • Mipseta
    05/03/2023

    Breast carcinomas lose the typical histology and architecture of normal breast glands <a href=[Link deleted]cialis or viagra Often comes in Liquid in 0

  • 打开Binance账户
    05/10/2023

    Thank you for your sharing. I am worried that I lack creative ideas. It is your article that makes me full of hope. Thank you. But, I have a question, can you help me? [Link deleted]

  • Notruro
    05/11/2023

    They show up with a creatinine level of 8 mg dL and a potassium level of 7 mmol L, and it s check mate, time for dialysis <a href=[Link deleted]cialis 5mg Higgins JA, Davis AR

  • binance sign up
    05/30/2023

    Your enticle helped me a lot, is there any more related content? Thanks! [Link deleted]

  • Binance推荐
    06/24/2023

    Your point of view caught my eye and was very interesting. Thanks. I have a question for you. [Link deleted]

  • lOmjUfjVS
    07/10/2023

    We can actually see the follicle developing in the ovary with a simple ultrasound test and know exactly when she ovulates by when the follicle disappears or reduces in size, and we can avoid the emotional drain of literally years of fruitless testing and slingshot- style therapy <a href=[Link deleted]hour cialis online

  • IuaMdrS
    07/14/2023

    In fact, those who undergo IVF often have spotting or bleeding approximately two weeks after the transfer <a href=[Link deleted]cialis online

  • rob
    07/17/2023

    We will update this as soon as possible. If you like to help, you can contact us. Dogecoin’s implementation differs from its predecessors: It was originally forked from Litecoin, then refactored to Bitcoin. Dogecoin’s target block time is 1 minute, as opposed to Litecoin’s 2.5 minutes and Bitcoin’s 10 minutes. The move, which sent Dogecoin prices more than 14% higher at one point, comes a month after Mr Musk said Tesla would test out the digital token as a payment option. As of 30 June 2015, the 100 billionth Dogecoin had been dug up, while Bitcoin’s final coin will be mined in 2140. An additional 5.256 billion DOGE are created every year and the supply is said to be infinite. Dogecoin and Shiba Inu are two different cryptocurrencies. Aside from both crypto coins having a Shiba Inu dog as a logo, the underlying technologies and distributions are fundamentally different. Dogecoin operates on a proof-of-work (PoW) consensus and is jointly mined with Litecoin, while SHIB is a token on the Ethereum network. In 2021, SHIB briefly overtook DOGE in market capitalization, starting the dog fight among the two cryptocurrencies.
    [Link deleted]
    Stay connected via It’s pretty basic: to pay your tax bill, you’ll need to know the amount of your cumulative gains or losses. In what follows, we’ll outline how to calculate crypto gains so you’ll in turn know how to calculate crypto taxes.. Again, a crypto taxes calculator can be a big help through this process. Total realized gains for Ethereum were slightly higher than those for Bitcoin for the period. Ethereum gains were $76.3 billion globally, compared to $74.7 billion for Bitcoin. The research attributed this to demand for DeFi with Ethereum being the global standard: Find out what you need to know about cryptoassets and your tax obligations. Showroom lists the most relevant tokens in the market today. The ranking is based on user behaviour and price data. The United States leads by a wide margin at an estimated $47.0 billion in realized cryptocurrency gains, followed by the UK, Germany, Japan, and China. However, like last year, we see many countries whose collective cryptocurrency investment performance seems to be outperforming their rankings in traditional measures of economic prosperity.

  • LiJSaqs
    07/27/2023

    Tangeretin Synergizes with 5 Fluorouracil to Induce Autophagy through MicroRNA 21 in Colorectal Cancer Cells <a href=[Link deleted]online cheap

  • CCFNiv
    08/17/2023

    <a href=[Link deleted]for hair loss We assessed the effects of postmastectomy radiotherapy on quality of life QOL in women with intermediate risk breast cancer

  • 20bet
    09/01/2023

    Your article gave me a lot of inspiration, I hope you can explain your point of view in more detail, because I have some doubts, thank you.

  • Vanna
    09/06/2023

    We’ve been provided with an bonus code “RWE2” by AMPM Casino – sign up here in this casino using our link and claim the promo code to trigger 20 Free Spins No Deposit that can be used to play “Ragnawolves WildEnergy” video slot provided by Yggdrasil! Wildz casino online also offers players the chance to advance through levels within the casino. The first level up leads to a free level up the following day, and players can also win casino bonuses and free spins on their favourite slot games. This feature is called Levelz and players only need bet a minimum of $0.20 in order to advance up the progress bar. Jackpot Jill casino offers slots of the highest quality and they form the bulk of the casino’s game portfolio. Classic slots, 5-reel video slots, 3D slots, progressive slots – name it and it is yours to play!
    [Link deleted]
    About the casino: Mandarin Palace casino is a neglected, small online gambling platform, which belongs to the infamous Genesys Group of online casinos. You can see the latest updates to The Mandarin Palace casino’s terms and conditions here. by Simon | Casino Reviews, Mandarin Palace Casino Review | 0 comments by Simon | Casino Reviews, Mandarin Palace Casino Review | 0 comments by Simon | Casino Reviews, Mandarin Palace Casino Review | 0 comments There are two very different types when it comes to online casinos, casinos, which accept US players, and casinos which do not accept US players. Mandarin Palace is firmly the former, not accepting players from the USA or US territories. Mandarin Palace Casino appears on 2 blacklists, but they haven’t influenced our rating of this casino. We’ve chosen to ignore them either because they’re related to the casino’s previous owner, or because some other applicable reasons.

  • 20bet
    09/24/2023

    I am currently writing a paper and a bug appeared in the paper. I found what I wanted from your article. Thank you very much. Your article gave me a lot of inspiration. But hope you can explain your point in more detail because I have some questions, thank you. <a href="[Link deleted]

  • бнанс Рестраця
    01/31/2024

    Can you be more specific about the content of your article? After reading it, I still have some doubts. Hope you can help me. [Link deleted]

Leave a Reply

Your email address will not be published.